Convox Community

Convox deployment failing with "Rule does not support attribute"

aws/cfm plic-apps-plic-memoirs UPDATE_FAILED TimerCleanup Embedded stack arn:aws:cloudformation:us-east-1::stack/ was not successfully updated. Currently in UPDATE_ROLLBACK_IN_PROGRESS with reason: [Error] /Resources/LauncherPermission/Properties/SourceArn/Fn::GetAtt: Resource type AWS::Events::Rule does not support attribute {Arn}

Starting at around 2 PM on 10/3, I can’t do any application deploys. They fail with an error message like the one above. I don’t really understand what the error is or why it started all of a sudden. The only thing I can think of is that it was a rack update. I have the following rack update 20191001204055 43 minutes ago which is about 2PM so that seems right. But I got a notification that the rack update was happening yesterday around 4PM: Updating rack to: version 20191001204055 and deployments yesterday and this morning all continued to work.

I tried rolling back to the previous rack version: 20190925233521 16 minutes ago but I am still having the same issues. I even tried a fresh release after rolling the rack back just in case it still had a bad template in there from the old rack release, but still no good. Anyone have any ideas of how to fix this or what might be going wrong?

Also experiencing the same issue, and we are on an older rack 20190808190811

Interesting. I just tried one of our racks that hasn’t ever been updated since being created (which isn’t good, but did provide another test point). Trying to deploy an application that worked find yesterday failed on a rack with the version 20190529174125. So this is definitely independent of the rack version.

This just started happening to us this afternoon. Deployments that previously worked have started erroring, and rack updates give the same error.
One rack is on 20190918145319 and the other is 20190905141723

Looks like it might not have anything to do with Convox: https://www.reddit.com/r/aws/comments/dcxz7y/fyi_aws_cloudformation_issues_in_useast1/

Though in traditionally crappy fashion, AWS hasn’t updated their status page: https://status.aws.amazon.com/

1 Like

Looks like deploys are working again so it is over whatever happened.