Convox Community

Version 3.x stopped working with Gen1 racks?

I’ve installed the latest convox CLI (3.0.2) on a new laptop, I am able to ‘log in’ to our rack however convox racks lists nothing (just the table headers and no racks), and trying any command mandates that I use convox switch to select a rack.

We’re on a private rack and don’t use the convox Console. I have tried setting CONVOX_HOST and I still get no racks listed.

The 3.x CLI has local rack management built in via Terraform so direct interaction with Racks has changed a bit.

You can communicate directly with a Rack by setting the RACK_URL environment variable.

Thanks @ddollar

This isn’t documented anywhere at all.

For anybody else needing to know how to use RACK_URL some digging shows it’s in the format:

https://convox:<RACK-PASSWORD>@<RACK-HOST>

@ddollar - Still not able to deploy with the latest CLI, it’s mandating a convox.yml file, that doesn’t exist for Gen 1 (docker-compose.yml). I’ve tried using the --manifest parameter and it’s ignored.

It basically looks like Gen 1 has stopped working for users since the last update.

Is there any way I can revert to install previous versions of the CLI so that we’re not stuck with deployments before we attempt a migration to Gen 2 or 3?

This might help @edward:

Basically, install two CLIs – in the docs, they rename it “convox-old”.

Thanks @scott1 - this assumes you already had an old version of the CLI on your machine.

I’m looking for a Convox download location for previous versions of the CLI, so I can install it fresh.
(Or for the existing CLI to support Gen1 racks…)

Click version 2 of the docs at the bottom of the current docs page to get the old download link.

Thanks @scott1, I see the download URLs between the docs are different which also wasn’t clear. I don’t really get how something can have so little documentation.

Anyway, this seems to have solved the issue in the short term, thank you much appreciated.

For anyone else arriving at the issue here’s the link: https://docsv2.convox.com/introduction/installation

Inline - Old Convox CLI Installation:

OS X

$ curl -L https://convox.com/cli/macos/convox -o /tmp/convox
$ sudo mv /tmp/convox /usr/local/bin/convox
$ sudo chmod 755 /usr/local/bin/convox

Linux

$ curl -L https://convox.com/cli/linux/convox -o /tmp/convox
$ sudo mv /tmp/convox /usr/local/bin/convox
$ sudo chmod 755 /usr/local/bin/convox

Windows

$ curl -L https://convox.com/cli/windows/convox.exe -O

Building Generation 1 apps should work with the new CLI. There must be some other issue. Please file a support ticket with your manifest file, the build command you’re running, and the errors you are seeing and we’d be happy to take a look.

$ convox -v
3.0.5

$ convox apps info -a httpd1
Name        httpd1
Status      running
Generation  1
Locked      false
Release     RNJCVTEGHLK

$ ls
Dockerfile         README.md          docker-compose.yml

$ convox build -a httpd1 -m docker-compose.yml
Packaging source... OK
Uploading source... OK
Starting build... OK
Authenticating xxx.dkr.ecr.us-east-1.amazonaws.com: Login Succeeded
running: docker tag httpd1/web xxx.dkr.ecr.us-east-1.amazonaws.com/dev-httpd1-rcanvbzjfk:web.BWSHSWQMOEC
running: docker push xxx.dkr.ecr.us-east-1.amazonaws.com/dev-httpd1-rcanvbzjfk:web.BWSHSWQMOEC
The push refers to repository [xxx.dkr.ecr.us-east-1.amazonaws.com/dev-httpd1-rcanvbzjfk]
3f8d3a1c8148: Preparing
e02e6276ec45: Preparing
b99a0f549e6c: Preparing
36e69e3e1c8c: Preparing
488dfecc21b1: Preparing
e02e6276ec45: Layer already exists
36e69e3e1c8c: Layer already exists
b99a0f549e6c: Layer already exists
488dfecc21b1: Layer already exists
3f8d3a1c8148: Layer already exists
web.BWSHSWQMOEC: digest: sha256:1e0cddb4e8282099b384d44232e1edc1eb91c033d774f432f3f68dd7b193b3b1 size: 1367
Build:   BWSHSWQMOEC
Release: RVBWYKQKESW