Convox Community

Error while trying to install local rack

I just tried to install convox on another machine and with the latest two version I get ERROR: update error: exit status 1.

After downgrading convox to version 20190319152401 it seems to work again.

After a successful install it seems like I can convox rack update without errors (but rack install still fails).

I have the same issue, verified on two computers.

Having very similar issues here. Verified on several linux distros all running ubuntu 18.04 and even on a windows 10 install we resorted to trying because we were out of options. Issues are either dial tcp connection refused errors, errors stuck waiting for rack after local install, failing to find the the local rack when doing a convox switch.

I’ve tried resetting kubernetes to factory, reinstalling the local rack several times and nothing has worked. Our mac workstations remain unaffected.

We have found the issue to be present on formerly working windows, linux computers alongside certain Macs

I just tried to follow the basic setup instructions to try this application out using OS X (10.13.6).

It timeouts after the after the sudo convox rack install local then when I attempt to try the next command convox start it fails as well:

ERROR: Get https://rack.convox/system?: dial tcp 10.101.162.71:443: i/o timeout

Any other convox commands appear to hang including convox rack logs.

When I do a docker ps, I see three containers k8s_main_api, k8s_main_router, and k8s_main_registry.

I’ve attempted a couple of reinstalls, removed containers, but nothing appears to be working. I’d really like to test this software out to see if it’s a fit for my company.

Okay, so I was able to fix this on my machine running OS X (10.13.6) . I did a full uninstall of docker (using the uninstall option in the gui and using appcleaner after just to be sure). Did a rm -R ~/.convox re-ran sudo convox update and then sudo convox login as per the docs. Then I installed the edge version of docker from docker hub, enabled kubernetes and all seems to be well currently. I will update if anything changes.

This also happened to me on convox 20190418192208, but I ran the command over again a few times and eventually it worked.