Security tokens are no longer working in the CLI

I recently updated my Convox CLI version and now it no longer detects any connected security keys. Here’s the error I get:

$ convox version
client: 3.3.3
Waiting for security token... ERROR: no valid tokens found

I tried several different hardware keys and the same thing happens. I’m running OS X 11.6.4 on an Intel CPU and here are my system details:

$ uname -a
Darwin MacBook-Pro.localdomain 20.6.0 Darwin Kernel Version 20.6.0: Wed Jan 12 22:22:42 PST 2022; root:xnu-7195.141.19~2/RELEASE_X86_64 x86_64

I was only able to get this working after I downgraded to an older release of the CLI binary. I traced through the most recent releases and convox-macos under release 3.2.5 was the last version that worked. The first version that exhibits this error for me is convox-macos under release 3.3.0

Has anyone else experienced this behavior? I see there’s an active issue related to U2F/WebAuthn along with convox/convox#420 and convox/rack#3497.

It’s working for me on macOS 12.2.1 with Convox CLI version 3.3.4, but when I’m being challenged for my security key, I’ve consistently had it fail the first two attempts, so I have to run the command three times:

$ convox apps params --rack=my-org/my-rack --app=my-app
# returns immediately with:
Waiting for security token... ERROR: hidapi: hid_error is not implemented yet

$ convox apps params --rack=my-org/my-rack --app=my-app
# makes my key flash once, but when I touch it, responds with:
Waiting for security token... ERROR: hidapi: hid_error is not implemented yet

$ convox apps params --rack=envato-content/content-author-apps-production --app=author-platform
Waiting for security token... OK

Hi @nickf

We fixed this issue with release 3.3.4, could you update and test again?


Hi @liam.dawson

Are you using the amd64 or arm64? Are you using the convox console?


arm64, and using the Convox Console.

@liam.dawson we will release a fix in the next couple of days, thanks for reporting the problem.

@taynan has a fix for this been released?

I still get that “Waiting for security token… ERROR: no valid tokens found” on an arm64 mac with the cli on convox version 3.4.4.

hi @kris, yes it was released a few months ago. I’ll see what’s happening and I’ll keep you posted. Thanks for pointing this out.

@kris you can use the amd64 CLI in emulation mode, the Yubikey works normally, until we release the fix for arm64.

@taynan. This appears to be working now with convox CLI version 3.5.1 on arm64. Was there a fix specifically for this or am I getting lucky?

@kris no, we haven’t released a fix yet. Is your Yubikey working properly?
Thanks for letting us know.

Hi @kris! We use a 3rd party tool to build the CLI for macOS arm64, they released a new version a few days ago that fixed the problem. Thanks for your contribution.