Convox Community

Rollback when trying to deploy

I’ve spun up a new AWS K8s rack, created an app, and tried to deploy to it. Both times, it completes the build process, says promoting and seems to error in the same place each time. Any idea where I could go to find more information on what’s happening?

Promoting RIHKSXBRBHU... 
2020-02-18T23:11:07Z system/k8s/web Scaled up replica set web-5c8c565c97 to 1
2020-02-18T23:11:07Z system/k8s/atom/app Status: Pending => Error
2020-02-18T23:11:07Z system/k8s/atom/app Status: Error => Rollback
2020-02-18T23:11:07Z system/k8s/atom/app Status: Rollback => Reverted
2020-02-18T23:11:08Z system/k8s/web-5c8c565c97-ngkmm Pulling image "736910391993.dkr.ecr.us-east-1.amazonaws.com/backendkubs/backend-prod:web.BENTWMHBGCF"
2020-02-18T23:11:13Z system/k8s/web-5c8c565c97-ngkmm Successfully pulled image "736910391993.dkr.ecr.us-east-1.amazonaws.com/backendkubs/backend-prod:web.BENTWMHBGCF"
2020-02-18T23:11:14Z system/k8s/web-5c8c565c97-ngkmm Created container main
2020-02-18T23:11:14Z system/k8s/web-5c8c565c97-ngkmm Started container main
ERROR: rollback

I found the problem by going to cloudwatch and selecting the loggroup: /convox/RACKNAME/system. The timer had an invalid value (though it worked in gen.2).

1 Like