# High error rate on syslog resource Lambda

**URL:** <https://community.convox.com/t/high-error-rate-on-syslog-resource-lambda/539>\
**Category:** Rack (Version 2)\
**Created:** [May 23, 2019, 3:52pm UTC](https://community.convox.com/t/high-error-rate-on-syslog-resource-lambda/539 "2019-05-23T15:52:53Z")\
**Posts on this page:** 1\
**Page:** 1

<div class="post-metadata">

**Author:** ![julian](https://yyz1.discourse-cdn.com/flex029/user_avatar/community.convox.com/julian/32/35_2.png) [@julian](https://community.convox.com/u/julian)\
**Post date:** [May 23, 2019, 3:52pm UTC](https://community.convox.com/t/high-error-rate-on-syslog-resource-lambda/539/1 "2019-05-23T15:52:53Z")

</div>

We just noticed our Lambda error rate was pretty high. Turns out the culprit was our syslog resources, e.g. `myrack-syslog-papertrail-Function-XXXXXXXXX`. We noticed because of the Papertrail outage yesterday, but it seems like even when Papertrail is working the error rate is pretty high.

Looking at the Cloudtrail logs for the Lambda, I’m seeing a lot of these:

`ioutil.ReadFile err=open /tmp/url: no such file or directory`

Not sure if this is the main error, but the success rate for the lambda function is around 65%.
