# Creating rack with IAM AccessDenied

**URL:** <https://community.convox.com/t/creating-rack-with-iam-accessdenied/747>\
**Category:** Rack (Version 3)\
**Created:** [May 25, 2020, 7:40am UTC](https://community.convox.com/t/creating-rack-with-iam-accessdenied/747 "2020-05-25T07:40:04Z")\
**Posts on this page:** 1\
**Page:** 1

<div class="post-metadata">

**Author:** ![bliaxiong](https://avatars.discourse-cdn.com/v4/letter/b/ad7895/32.png) [@bliaxiong](https://community.convox.com/u/bliaxiong)\
**Post date:** [May 25, 2020, 7:40am UTC](https://community.convox.com/t/creating-rack-with-iam-accessdenied/747/1 "2020-05-25T07:40:05Z")

</div>

I’ve been trying to create a rack from my mac to AWS and keep hitting an error, I don’t know if this is new or has been resolved. I just started playing around with Convox this weekend. It seems to create a rack fine through the web UI console. I’m using convox cli version 3.0.18. I did check the IAM role ‘dev1-cluster’ and it doesn’t have that ability in the policy.

```
Installing/creating rack error:
Error: Waiting for service "dev1-system/router" to assign IP/hostname for a load balancer
router (Service): SyncLoadBalancerFailed: Error syncing load balancer: failed to ensure load balancer: error creating load balancer: "AccessDenied: User: arn:aws:sts::xxx:assumed-role/dev1-cluster/1590373000968007034 is not authorized to perform: ec2:DescribeAccountAttributes\n\tstatus code: 403, request id: 33d8a394-be66-4248-8dac-5f8024d02888"
```
