# Rack (Version 2)

**URL:** https://community.convox.com/c/rack-v2/5.md

[Latest](https://community.convox.com/latest.md) · [Categories](https://community.convox.com/categories.md)

---

## [Migrating from an Amazon Linux 2 to an Amazon Linux 2023 Amazon ECS-optimized AMI](https://community.convox.com/t/migrating-from-an-amazon-linux-2-to-an-amazon-linux-2023-amazon-ecs-optimized-ami/982)

<div class="topic-metadata">

**Author:** [@eravelo](https://community.convox.com/u/eravelo)\
**Replies:** 4\
**Last updated:** [July 7, 2026, 2:44pm UTC](https://community.convox.com/t/migrating-from-an-amazon-linux-2-to-an-amazon-linux-2023-amazon-ecs-optimized-ami/982 "2026-07-07T14:44:23Z")

</div>

Hello Convox community, Is there a plan for a V2 Rack release to address this AWS announcement? Following Amazon Linux, Amazon ECS ends standard support for Amazon Linux 2 Amazon ECS-optimized AMIs effective June 30, …

---

## [Amazon ECS will discontinue support for short service Amazon Resource Names](https://community.convox.com/t/amazon-ecs-will-discontinue-support-for-short-service-amazon-resource-names/975)

<div class="topic-metadata">

**Author:** [@eravelo](https://community.convox.com/u/eravelo)\
**Replies:** 3\
**Last updated:** [July 7, 2025, 8:42am UTC](https://community.convox.com/t/amazon-ecs-will-discontinue-support-for-short-service-amazon-resource-names/975 "2025-07-07T08:42:27Z")

</div>

Hello Convox Community We recently received this notification from AWS: Starting April 4, 2026, Amazon ECS will discontinue support for short service Amazon Resource Names (ARNs) and automatically migrate any ECS serv…

---

## [How to disable ECS availability zone rebalancing?](https://community.convox.com/t/how-to-disable-ecs-availability-zone-rebalancing/977)

<div class="topic-metadata">

**Author:** [@xtagon](https://community.convox.com/u/xtagon)\
**Replies:** 1\
**Last updated:** [June 30, 2025, 4:29pm UTC](https://community.convox.com/t/how-to-disable-ecs-availability-zone-rebalancing/977 "2025-06-30T16:29:47Z")

</div>

AWS sent notice that they are going to enable AZ Rebalancing by default on ECS services on June 30, 2025. There is an option to set enableAvailabilityZoneRebalancing to false in order to opt an ECS service out of this. H…

---

## [Convox still using Node 16.x on AWS Lambda](https://community.convox.com/t/convox-still-using-node-16-x-on-aws-lambda/976)

<div class="topic-metadata">

**Author:** [@xtagon](https://community.convox.com/u/xtagon)\
**Replies:** 0\
**Last updated:** [June 4, 2025, 9:11pm UTC](https://community.convox.com/t/convox-still-using-node-16-x-on-aws-lambda/976 "2025-06-04T21:11:27Z")

</div>

Hi, We recently updated our racks to use Node.js v20 as \<= 18 is deprecated. However, in our AWS account we still have two Lambda functions/apps that are stuck on Node v16, and we’re not sure how to update them, or real…

---

## [CLI operations fail w/deployment keys](https://community.convox.com/t/cli-operations-fail-w-deployment-keys/966)

<div class="topic-metadata">

**Author:** [@nathan](https://community.convox.com/u/nathan)\
**Replies:** 3\
**Last updated:** [March 11, 2025, 6:04pm UTC](https://community.convox.com/t/cli-operations-fail-w-deployment-keys/966 "2025-03-11T18:04:41Z")

</div>

We started seeing an authentication failure error today when trying to authenticate via CONVOX\_PASSWORD. ERROR: authentication failed I’ve regenerated the deploy key we’re using but that didn’t make a difference. Has s…

---

## [Upgrading rack destroyed it](https://community.convox.com/t/upgrading-rack-destroyed-it/959)

<div class="topic-metadata">

**Author:** [@tech](https://community.convox.com/u/tech)\
**Replies:** 1\
**Last updated:** [February 24, 2025, 8:41pm UTC](https://community.convox.com/t/upgrading-rack-destroyed-it/959 "2025-02-24T20:41:50Z")

</div>

We upgraded from rack 20220427210019 to 20241112202208 and the rack is completely unreachable but the web app is still running. New ec2 instances were created by the rack upgrade, but now all convox commands (except conv…

---

## [Cannot rotate rack access?](https://community.convox.com/t/cannot-rotate-rack-access/957)

<div class="topic-metadata">

**Author:** [@phuongnd08](https://community.convox.com/u/phuongnd08)\
**Replies:** 0\
**Last updated:** [October 31, 2024, 7:38am UTC](https://community.convox.com/t/cannot-rotate-rack-access/957 "2024-10-31T07:38:47Z")

</div>

Getting error when running convox rack access key rotate Output: ERROR: 0 args required Look like the command is removed?

---

## [Amazon ECS-Optimized Amazon Linux 2 AMIs moving to use Docker v25.0.3](https://community.convox.com/t/amazon-ecs-optimized-amazon-linux-2-amis-moving-to-use-docker-v25-0-3/947)

<div class="topic-metadata">

**Author:** [@eravelo](https://community.convox.com/u/eravelo)\
**Replies:** 3\
**Last updated:** [July 29, 2024, 1:54pm UTC](https://community.convox.com/t/amazon-ecs-optimized-amazon-linux-2-amis-moving-to-use-docker-v25-0-3/947 "2024-07-29T13:54:23Z")

</div>

Hello there, Received this notification from AWS: We are contacting you about an upcoming change to the Docker version used in the Amazon ECS-Optimized AMIs based on Amazon Linux 2 (AL2). Amazon ECS-Optimized AL2 AMIs…

---

## [Expiring certificate not rolled out when new one is available](https://community.convox.com/t/expiring-certificate-not-rolled-out-when-new-one-is-available/942)

<div class="topic-metadata">

**Author:** [@mvpl](https://community.convox.com/u/mvpl)\
**Replies:** 1\
**Last updated:** [March 19, 2024, 5:46pm UTC](https://community.convox.com/t/expiring-certificate-not-rolled-out-when-new-one-is-available/942 "2024-03-19T17:46:25Z")

</div>

Hello, how rack version 2 manages acm certificates ? we have wildcard certificate which is on certificate lists however after promoting new release the old certificate is still pinned, so ACM and convox certs show both…

---

## [Certificate errors when starting a build](https://community.convox.com/t/certificate-errors-when-starting-a-build/938)

<div class="topic-metadata">

**Author:** [@nathan](https://community.convox.com/u/nathan)\
**Replies:** 6\
**Last updated:** [February 7, 2024, 1:49am UTC](https://community.convox.com/t/certificate-errors-when-starting-a-build/938 "2024-02-07T01:49:09Z")

</div>

We have two racks and starting this morning one of them has been failing to build correctly. When we run convox build, we get the following error: Packaging source... OK Uploading source... OK Starting build... ERROR: …

---

## [Disabling EC2 instance public IPV4 addresses](https://community.convox.com/t/disabling-ec2-instance-public-ipv4-addresses/939)

<div class="topic-metadata">

**Author:** [@scott](https://community.convox.com/u/scott)\
**Replies:** 1\
**Last updated:** [January 24, 2024, 2:03pm UTC](https://community.convox.com/t/disabling-ec2-instance-public-ipv4-addresses/939 "2024-01-24T14:03:42Z")

</div>

AWS is going to start charging for ip addresses: New – AWS Public IPv4 Address Charge + Public IP Insights | AWS News Blog. Is there a way to disable public ipv4 addresses on our EC2 instances? I see that there is an o…

---

## [AWS Lambda end of support for the Go 1.x runtime](https://community.convox.com/t/aws-lambda-end-of-support-for-the-go-1-x-runtime/931)

<div class="topic-metadata">

**Author:** [@mvpl](https://community.convox.com/u/mvpl)\
**Replies:** 4\
**Last updated:** [November 22, 2023, 1:09am UTC](https://community.convox.com/t/aws-lambda-end-of-support-for-the-go-1-x-runtime/931 "2023-11-22T01:09:40Z")

</div>

AWS ending support for go runtime in lambda, currently we have rack which is using it, any plans to bump version/rewrite it in next rack releases ? Original AWS message: “We are ending support for the Go 1.x runtime in…

---

## [BUG: editing environment variable applies to last "not active" build](https://community.convox.com/t/bug-editing-environment-variable-applies-to-last-not-active-build/933)

<div class="topic-metadata">

**Author:** [@mvpl](https://community.convox.com/u/mvpl)\
**Replies:** 2\
**Last updated:** [September 26, 2023, 3:43pm UTC](https://community.convox.com/t/bug-editing-environment-variable-applies-to-last-not-active-build/933 "2023-09-26T15:43:19Z")

</div>

since convox v1 editing environment variable was creating new release based on build which is currently promoted , now after migrating to v2 , we observe that editing variable will took latest build as a source, not the …

---

## [Amazon EFS - Risk of access interruption due to misconfigured EFS mounts](https://community.convox.com/t/amazon-efs-risk-of-access-interruption-due-to-misconfigured-efs-mounts/932)

<div class="topic-metadata">

**Author:** [@asd](https://community.convox.com/u/asd)\
**Replies:** 4\
**Last updated:** [September 17, 2023, 2:14am UTC](https://community.convox.com/t/amazon-efs-risk-of-access-interruption-due-to-misconfigured-efs-mounts/932 "2023-09-17T02:14:31Z")

</div>

Hey there. We’ve received the notification below from AWS, and apparently when mounting EFS volumes (by means of having defined volumes in convox.yml) noresvport mount option should be specified. First of all, do you t…

---

## [Rack V2 does not proxy the correct port](https://community.convox.com/t/rack-v2-does-not-proxy-the-correct-port/926)

<div class="topic-metadata">

**Author:** [@eravelo](https://community.convox.com/u/eravelo)\
**Replies:** 5\
**Last updated:** [September 13, 2023, 2:55pm UTC](https://community.convox.com/t/rack-v2-does-not-proxy-the-correct-port/926 "2023-09-13T14:55:30Z")

</div>

Hello all, After updating to latest version (20230619214423) of the CLI and the Rack, the rack resources proxy command does not seem to work anymore. It proxies to port 80, which is strange for a MySQL resource: $ conv…

---

## [Disabling port 80](https://community.convox.com/t/disabling-port-80/930)

<div class="topic-metadata">

**Author:** [@alon](https://community.convox.com/u/alon)\
**Replies:** 3\
**Last updated:** [August 15, 2023, 12:02pm UTC](https://community.convox.com/t/disabling-port-80/930 "2023-08-15T12:02:11Z")

</div>

Hi there, We’re going through SoC2 certification. We still use Rack v2. Convox documentation says: The Convox router listens on ports 80 and 443 and handles SSL termination for you. You will need to define the port o…

---

## [Log storage in S3 stopped](https://community.convox.com/t/log-storage-in-s3-stopped/929)

<div class="topic-metadata">

**Author:** [@alon](https://community.convox.com/u/alon)\
**Replies:** 0\
**Last updated:** [August 9, 2023, 3:42pm UTC](https://community.convox.com/t/log-storage-in-s3-stopped/929 "2023-08-09T15:42:44Z")

</div>

Hi there, @Nick-Convox hoping you can help. Around 1 year ago, logging of our app logs to the S3 bucket stopped. This is the location I am talking about: s3://rackname-logs-somecode/convox/logs/rackname-appname/s3/ I…

---

## [App in failed status](https://community.convox.com/t/app-in-failed-status/911)

<div class="topic-metadata">

**Author:** [@paolo.palmonari](https://community.convox.com/u/paolo.palmonari)\
**Replies:** 1\
**Last updated:** [June 27, 2023, 12:45am UTC](https://community.convox.com/t/app-in-failed-status/911 "2023-06-27T00:45:40Z")

</div>

I have one app in my version 2 rack which is in failed status. convox apps -r prod … content-collector-g2 failed RJYIIULKWAM … In the last release promote, helthcheck faild, the reason was because the first thin…

---

## [Enabling Container insights on Rack V2](https://community.convox.com/t/enabling-container-insights-on-rack-v2/910)

<div class="topic-metadata">

**Author:** [@eravelo](https://community.convox.com/u/eravelo)\
**Replies:** 1\
**Last updated:** [December 29, 2022, 12:37pm UTC](https://community.convox.com/t/enabling-container-insights-on-rack-v2/910 "2022-12-29T12:37:35Z")

</div>

What is the good approach to enable Container insights on the ECS Cluster of a V2 Rack? My concern is how to enable Instance Level Insights? Because I don’t like to use AWS cli to modify the Convox Rack, I tried the ag…

---

## [Not enough memory to start process](https://community.convox.com/t/not-enough-memory-to-start-process/909)

<div class="topic-metadata">

**Author:** [@engineering1](https://community.convox.com/u/engineering1)\
**Replies:** 0\
**Last updated:** [December 22, 2022, 8:14pm UTC](https://community.convox.com/t/not-enough-memory-to-start-process/909 "2022-12-22T20:14:48Z")

</div>

I see that my BuildMemory is set to 1024, is there any way to reset the instance or something? Suddenly I’m getting this error every time I try to build anything. I tried upping the memory limit but apparently that sta…

---

## [Any ideas why the workflow isn't firing?](https://community.convox.com/t/any-ideas-why-the-workflow-isnt-firing/908)

<div class="topic-metadata">

**Author:** [@scott1](https://community.convox.com/u/scott1)\
**Replies:** 0\
**Last updated:** [December 22, 2022, 2:14am UTC](https://community.convox.com/t/any-ideas-why-the-workflow-isnt-firing/908 "2022-12-22T02:14:45Z")

</div>

I just set up a review workflow but it doesn’t seem to trigger when I push a commit to a branch. My branch pattern is .\* Any ideas?

---

## [AWS notice: Recommendation to not use launch configurations](https://community.convox.com/t/aws-notice-recommendation-to-not-use-launch-configurations/905)

<div class="topic-metadata">

**Author:** [@eravelo](https://community.convox.com/u/eravelo)\
**Replies:** 2\
**Last updated:** [December 1, 2022, 7:13am UTC](https://community.convox.com/t/aws-notice-recommendation-to-not-use-launch-configurations/905 "2022-12-01T07:13:43Z")

</div>

Hi, We recently received this notification email from AWS: “We have identified that one or more of your accounts uses Amazon EC2 Auto Scaling launch configurations. After December 31, 2022 no new Amazon Elastic Compute…

---

## [BUG: Docker TLS mode broke \`docker run\` and \`docker exec\`](https://community.convox.com/t/bug-docker-tls-mode-broke-docker-run-and-docker-exec/898)

<div class="topic-metadata">

**Author:** [@asd](https://community.convox.com/u/asd)\
**Replies:** 1\
**Last updated:** [October 27, 2022, 9:47am UTC](https://community.convox.com/t/bug-docker-tls-mode-broke-docker-run-and-docker-exec/898 "2022-10-27T09:47:33Z")

</div>

Cross-posting from GitHub: After having updated one of our racks from 20220817173516 to 20221013170042 we’ve noticed, for example, convox exec \<pid\> sh --app \<app\> is broken and it will fail with the following error mes…

---

## [Where to find the new cpu and mem utilization percentage for rack processes?](https://community.convox.com/t/where-to-find-the-new-cpu-and-mem-utilization-percentage-for-rack-processes/893)

<div class="topic-metadata">

**Author:** [@asd](https://community.convox.com/u/asd)\
**Replies:** 1\
**Last updated:** [October 26, 2022, 8:20am UTC](https://community.convox.com/t/where-to-find-the-new-cpu-and-mem-utilization-percentage-for-rack-processes/893 "2022-10-26T08:20:39Z")

</div>

Cross-post: Release 20220721123319 adds cpu and mem utilization percentage for rack processes, however I am not able to see those neither via convox rack ps nor convox ps -a \<app\>. How these two new metrics are availabl…

---

## [InstanceRunCommand - cloud-init examples](https://community.convox.com/t/instanceruncommand-cloud-init-examples/892)

<div class="topic-metadata">

**Author:** [@jake](https://community.convox.com/u/jake)\
**Replies:** 0\
**Last updated:** [August 24, 2022, 5:58am UTC](https://community.convox.com/t/instanceruncommand-cloud-init-examples/892 "2022-08-24T05:58:34Z")

</div>

Has anyone been able to get the “InstanceRunCommand” to run a cloud-config file? For example: #cloud-config package\_update: true package\_upgrade: true users: - name: username sudo: ALL=(ALL) NOPASSWD:ALL gro…

---

## [Convox.site domain (ACM)](https://community.convox.com/t/convox-site-domain-acm/791)

<div class="topic-metadata">

**Author:** [@edward](https://community.convox.com/u/edward)\
**Replies:** 1\
**Last updated:** [August 17, 2022, 5:23pm UTC](https://community.convox.com/t/convox-site-domain-acm/791 "2022-08-17T17:23:02Z")

</div>

I’ve just enabled our Internal load balancer - and saw it was getting stuck at the certificate stage and hanging forever. I noticed that this was because it required the load-balancer’s \*\*\*-convox.site domain to be verif…

---

## [Diagnosing "ExpiredToken" errors](https://community.convox.com/t/diagnosing-expiredtoken-errors/887)

<div class="topic-metadata">

**Author:** [@nathan](https://community.convox.com/u/nathan)\
**Replies:** 0\
**Last updated:** [June 9, 2022, 10:05pm UTC](https://community.convox.com/t/diagnosing-expiredtoken-errors/887 "2022-06-09T22:05:10Z")

</div>

This afternoon we began receiving “expired token” errors when attempting to build in Convox. ERROR: ExpiredToken: The security token included in the request is expired status code: 403, request id: a371d0bd-8324…

---

## [BUG: Endpoints with existing VPC will break rack updates](https://community.convox.com/t/bug-endpoints-with-existing-vpc-will-break-rack-updates/884)

<div class="topic-metadata">

**Author:** [@asd](https://community.convox.com/u/asd)\
**Replies:** 6\
**Last updated:** [June 8, 2022, 12:02pm UTC](https://community.convox.com/t/bug-endpoints-with-existing-vpc-will-break-rack-updates/884 "2022-06-08T12:02:05Z")

</div>

Hi, We believe to hit a bug with the new “VPC endpoints” feature whilst attempting to update two of our racks from 20220310121318 to 20220427210019. We believe the bug is due to a series of releases starting from 20220…

---

## [EFS Volumes with Fargate services](https://community.convox.com/t/efs-volumes-with-fargate-services/875)

<div class="topic-metadata">

**Author:** [@nathan](https://community.convox.com/u/nathan)\
**Replies:** 0\
**Last updated:** [March 9, 2022, 6:24pm UTC](https://community.convox.com/t/efs-volumes-with-fargate-services/875 "2022-03-09T18:24:08Z")

</div>

With the release of Fargate platform v1.4 EFS volume mounts are now supported. We’d like to move some work to Fargate, but it appears that Convox currently handles Volumes by mounting the filesystem into the host instanc…

---

## [Not enough memory available with recent update](https://community.convox.com/t/not-enough-memory-available-with-recent-update/686)

<div class="topic-metadata">

**Author:** [@dazzler](https://community.convox.com/u/dazzler)\
**Replies:** 1\
**Last updated:** [March 2, 2022, 4:39pm UTC](https://community.convox.com/t/not-enough-memory-available-with-recent-update/686 "2022-03-02T16:39:04Z")

</div>

After updating my CLI and rack today I am unable to deploy an update to an app successfully due to ‘ERROR not enough memory available to start process’ on build. I have tried changing the cluster to 3 x 8GB (up from 4GB…

[Next page](https://community.convox.com/c/rack-v2/5.md?page=1)
